Vendredi 23 novembre 2018

2017-06-11-PC1-coredump

coredump

juin 08 14:54:41 yannick-pc systemd-coredump[557]: Process 472 (colord-sane) of user 124 dumped core.
                                                   
                                                   Stack trace of thread 477:
                                                   #0  0x00007fd59b40d670 raise (libc.so.6)

FS#54205 : (openssl) colord-sane aborts at exit, sometimes

Downgrading sane to 1.0.25-2 resolve this. I’m not sure if this is a sane or colord problem.

[root@yannick-pc yannick]# systemctl status colord
● colord.service - Manage, Install and Generate Color Profiles
   Loaded: loaded (/usr/lib/systemd/system/colord.service; static; vendor preset: disabled)
   Active: active (running) since Sun 2017-06-11 16:23:22 CEST; 21min ago
 Main PID: 443 (colord)
    Tasks: 3 (limit: 4915)
   CGroup: /system.slice/colord.service
           └─443 /usr/lib/colord/colord

juin 11 16:23:22 yannick-pc systemd[1]: Starting Manage, Install and Generate Color Profiles...
juin 11 16:23:22 yannick-pc systemd[1]: Started Manage, Install and Generate Color Profiles.
juin 11 16:23:22 yannick-pc colord[443]: failed to get session [pid 430]: Aucun périphérique ou adresse
juin 11 16:23:22 yannick-pc colord[443]: failed to get session [pid 430]: Aucun périphérique ou adresse
juin 11 16:23:24 yannick-pc colord[443]: GLib (gthread-posix.c): Unexpected error from C library during 'pthread_setspecific': Invalid argument.  Aborting.
[root@yannick-pc yannick]# systemctl stop colord
[root@yannick-pc yannick]# systemctl start colord
[root@yannick-pc yannick]# systemctl status colord
● colord.service - Manage, Install and Generate Color Profiles
   Loaded: loaded (/usr/lib/systemd/system/colord.service; static; vendor preset: disabled)
   Active: active (running) since Sun 2017-06-11 16:45:30 CEST; 2s ago
 Main PID: 1467 (colord)
    Tasks: 9 (limit: 4915)
   CGroup: /system.slice/colord.service
           ├─1467 /usr/lib/colord/colord
           └─1471 /usr/lib/colord/colord-sane

juin 11 16:45:30 yannick-pc systemd[1]: Starting Manage, Install and Generate Color Profiles...
juin 11 16:45:30 yannick-pc systemd[1]: Started Manage, Install and Generate Color Profiles.

Downgrading packages - ArchWiki

Il faut passer sane en version 1.02.25 et ne plus le mettre à jour temporairement

Utlisation du cache pacman qui contient la version antérieure

If a package was installed at an earlier stage, and the pacman cache was not cleaned, install an earlier version from /var/cache/pacman/pkg/.

This process will remove the current package and install the older version. Dependency changes will be handled, but pacman will not handle version conflicts. If a library or other package needs to be downgraded with the packages, please be aware that you will have to downgrade this package yourself as well.

# pacman -U /var/cache/pacman/pkg/sane-1.0.25-2-x86_64.pkg.tar.xz

Once the package is reverted, temporarily add it to the IgnorePkg section of /etc/pacman.conf, until the difficulty with the updated package is resolved.

IgnorePkg   = qownnotes sane

Utilisation des archives

wget https://archive.archlinux.org/packages/s/sane/sane-1.0.25-2-x86_64.pkg.tar.xz
sudo pacman -U sane-1.0.25-2-x86_64.pkg.tar.xz