Lundi 31 décembre 2018

Rsync

Rsync

Debian n’a pas la dernière version par rapport à archlinux (17/12/2018)
Debian rsync 3.1.2
Archlinux rsync 3.1.3
Il est impossible de synchroniser avec 2 versions différentes de rsync
Il faut compiler la dernière version rsync 3.1.3 sur debian

Pour compiler des programmes, vous aurez besoin avant toute chose d’installer les outils de compilation. Pour cela, rien de plus simple, il suffit d’installer le paquet build-essential

sudo apt-get install build-essential

Téléchargement du paquet

wget https://www.samba.org/ftp/rsync/src/rsync-3.1.3.tar.gz

MD5 sum: 1581a588fde9d89f6bc6201e8129afaf

md5sum rsync-3.1.3.tar.gz  1581a588fde9d89f6bc6201e8129afaf  rsync-3.1.3.tar.gz

Après vérification, décompresser

tar xzvf rsync-3.1.3.tar.gz 

aller dasn le dossier ,compiler et installer

cd rsync-3.1.3
./configure --prefix=/usr --without-included-zlib
make
sudo make install